
IDSC Holdings LLC retains all ownership rights to USB-Link 2 and its documentation. The USB-Link 2 source code is a confidential trade secret of IDSC Holdings LLC. You may not decipher or de-compile USB-Link 2, develop source code for USB-Link 2, or knowingly allow others to do so. The USB-Link 2 and its documentation may not be sublicensed or transferred without the prior written consent of IDSC Holdings LLC.

This manual, as well as the software it describes, is furnished under license and may only be used or copied in accordance with the terms of such license. The content of this manual is furnished for informational use only, is subject to change without notice, and should not be construed as a commitment by IDSC Holdings LLC. IDSC Holdings LLC assumes no responsibility or liability for any errors or inaccuracies that may appear in this book.

Except as permitted by such license, no part of this publication may be reproduced, or transmitted, in any form or by any means, electronic, mechanical, or otherwise, without the prior written permission of IDSC Holdings LLC.

NEXIQ Technologies and USB-Link are trademarks of IDSC Holdings LLC. The Bluetooth word mark and logos are registered trademarks owned by Bluetooth SIG. Other trademarks and trade names are those of their respective owners.

©2014-2015 IDSC Holdings LLC. All rights reserved. All other marks are trademarks or registered trademarks of the respective holders. Pictures for illustration purposes only. Specifications are subject to change without notice.

www.nexiq.com

This device complies with Part 15 of the FCC Rules. Operation is subject to the following two conditions: (1) this device may not cause harmful interference, and (2) this device must accept any interference received, including interference that may cause undesired operation. This device contains FCC-ID POOWML-C30XX.

Approved in accordance to R&TTE directive transmitter module marked by “CE product label”, manufactured by MITSUMI incorporated to OEM product.

Part No. 964059 Revised 08/13/2015
Table of Contents

Chapter 1:
Using this Manual .................................................................1
  Manual Overview .................................................................2
  Conventions ............................................................................3

Chapter 2:
Introducing the USB-Link™ 2 Bluetooth Edition ............5
  Component Checklist ..............................................................6
  Product Specifications ...........................................................7
  System Requirements ............................................................8
  Device Features .................................................................9
    The Reset Button ............................................................10
  Communication Options: Wired vs Wireless .....................11
    Wired Connection .............................................................11
    Wireless Connection .........................................................12

Chapter 3:
Installation and Bluetooth Configuration .....................13
  Installation Process Outline ...............................................14
  Step 1: Install the Drivers ...................................................15
  Step 2: Choose Your Connection .......................................24
    Wired Connection .............................................................24
    Wireless Connection ........................................................24
  Step 3: Install the Bluetooth Drivers .................................25
    Configure the Bluetooth Environment .............................26
# Table of Contents

Chapter 4: Preparing to Use the USB-Link™ 2 ................. 29

Step 4: Connect the USB-Link™ 2 to a Vehicle ................... 30
  Making the Connection ......................................................... 30
  Wired Connection Using a USB Cable ................................. 30
  Wireless Connection ............................................................ 31

Step 5: Pair the Device .......................................................... 32

Step 6: Test the Connection to the Vehicle ......................... 40

Using the USB-Link™ 2 Explorer ........................................... 43
  The Configuration Tab .......................................................... 45
  The File Menu ................................................................. 46
  The Tools Menu ............................................................... 47
    Ping ........................................................................... 47
    Options ......................................................................... 48
  The Help Menu ............................................................... 50
Chapter 1

Using this Manual

- Manual Overview, page 2
- Conventions, page 3

This chapter provides an overview of this manual’s organization and the conventions used throughout.

NOTE:

Screen shots used throughout this manual are for illustrative purposes only. All data shown is fictitious in nature.
Manual Overview

This manual provides basic and detailed information to support you during installation and setup of the USB-Link™ 2 Bluetooth® Edition.

This manual is composed of the following sections:

- **Table of Contents**—helps you to find the information you are looking for quickly and easily.
- **Chapter 1: Using this Manual**—provides an overview of this user’s manual.
- **Chapter 2: Introducing the USB-Link™ 2 Bluetooth Edition**—introduces the USB-Link™ 2 Bluetooth® Edition and provides details regarding the communication modes available to you to interface with your PC.
- **Chapter 3: Installation and Bluetooth Configuration**—provides instructions for installing NEXIQ™ drivers and utilities, installing the required Bluetooth® drivers, and configuring a basic Bluetooth® environment.
- **Chapter 4: Preparing to Use the USB-Link™ 2**—provides instructions for connecting the USB-Link™ 2 Bluetooth® Edition to a vehicle, pairing the device, and testing the connection. It also provides information on using the USB-Link™ 2 Explorer.

Each chapter begins with an “at-a-glance” list of the chapter contents, along with corresponding page numbers.
Conventions

This section provides descriptions of the conventions used throughout this guide.

Special Messages

Note

NOTE provides an explanation, comment, or tip related to the subject matter that is being discussed.

Example:

NOTE:

Refer to the page number provided for each described component for further details.

Important

IMPORTANT indicates a situation which, if not avoided, may result in damage to the test equipment or vehicle.

Example:

IMPORTANT:

Keep all cables clear of moving or hot engine parts.

Caution

CAUTION indicates a potentially hazardous situation which, if not avoided, may result in moderate or minor injury to the operator or to bystanders.

Example:

CAUTION:

Do not use the unit to perform tests on household or industrial sources.
**Warning**

WARNING indicates a potentially hazardous situation which, if not avoided, could result in death or serious injury to the operator or bystanders.

*Example:*

```
WARNING:

⚠️ All RP1210 adapters must be disconnected before proceeding with installation.
```

**Troubleshooting**

Information intended to help you to address or anticipate potential issues are presented in the following manner:

```
If NEXIQ WVL2 drivers are installed, the WVL2 Explorer Utility must be exited before proceeding with installation.
```

**Specialized Text**

The following specially formatted text is used to help you to differentiate certain elements discussed within this manual:

- **Emphasis:** Used to draw your attention to particularly important information.

  Example: “Click on the Finish button to continue.”

- **FEATURE:** Used to highlight the name of a specific feature.

  Example: “From the Start menu, select Programs ▶ NEXIQ ▶ Device Tester ▶ Device Tester.”

- **Field/Line:** Used to highlight the name of a field or a line of text from a display.

  Example: “A check mark is placed in the check box next to the Total Fuel Used parameter.”

- **Menu Items:** Used to highlight a series of menu selections.

  Example: “The Installation Complete screen is displayed.”
Chapter 2

Introducing the USB-Link™ 2 Bluetooth Edition

- Component Checklist, page 6
- Product Specifications, page 7
- System Requirements, page 8
- Device Features, page 9
  - The Reset Button, page 10
- Communication Options: Wired vs Wireless, page 11

The USB-Link™ 2 is a hardware device that enables service bay personal computers (i.e., PCs and/or laptops) to retrieve vehicle information using either wireless Bluetooth® technology or a more traditional cable connection. Once configured, the USB-Link™ 2 interfaces with your PC, enabling you to use specific PC applications to perform vehicle diagnostics.

This chapter introduces the USB-Link™ 2 Bluetooth® Edition and provides details regarding the communication modes available to you to interface with your PC.
Component Checklist

The following components are included with your USB-Link™ 2. Be sure you have all of the following items before using the device:

- USB-Link™ 2 Vehicle Communication Interface (VCI)
- Automotive A to Mini-B USB Cable (see Figure 2.2)
- 6- and 9-pin “Y” Deutsch Adapter
- Carrying Case
- USB-Link™ 2 Quick Start Guide
# Product Specifications

The USB-Link™ 2 is configured with the following specifications:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical Dimensions</td>
<td>6.75&quot; x 3.75&quot; x 1.06&quot; (171 mm x 95 mm x 27 mm)</td>
</tr>
<tr>
<td>Weight</td>
<td>8 oz. (0.22 kg)</td>
</tr>
<tr>
<td>Power Requirements</td>
<td>6 - 32 VDC @ 350 mA maximum</td>
</tr>
<tr>
<td>Operating Temperature</td>
<td>0 to +70 °C</td>
</tr>
<tr>
<td>API Driver</td>
<td>TMC RP1210A, RP1210B, and RP1210C compliant</td>
</tr>
<tr>
<td></td>
<td>SAE J2534 compliant</td>
</tr>
<tr>
<td>Vehicle Protocols Supported</td>
<td>• J1708/J1587</td>
</tr>
<tr>
<td></td>
<td>• J1939 (250K, 500K, or 1 MB)</td>
</tr>
<tr>
<td></td>
<td>• CAN (125K, 250K, 500K, 1 MB)</td>
</tr>
<tr>
<td></td>
<td>(3 CAN channels supported)</td>
</tr>
<tr>
<td></td>
<td>• J2284 CAN (125K, 250K, or 500K)</td>
</tr>
<tr>
<td></td>
<td>• ATEC-160 Baud</td>
</tr>
<tr>
<td></td>
<td>• ALDL Pass-through</td>
</tr>
<tr>
<td></td>
<td>• ALDL 8192</td>
</tr>
<tr>
<td></td>
<td>• ALDL 9600</td>
</tr>
<tr>
<td></td>
<td>• OBDII</td>
</tr>
<tr>
<td></td>
<td>• ISO 9141</td>
</tr>
<tr>
<td></td>
<td>• ISO 14230 (KWP2000)</td>
</tr>
<tr>
<td></td>
<td>• ISO 15765</td>
</tr>
<tr>
<td></td>
<td>• J1850 (PWM, VPM, or Allison)</td>
</tr>
<tr>
<td></td>
<td>• J1939 Auto Baud</td>
</tr>
<tr>
<td></td>
<td>• IESCAN (required for Allison)</td>
</tr>
<tr>
<td>USB Communication</td>
<td>USB Device, version 1.1</td>
</tr>
<tr>
<td>Wireless Communication</td>
<td>Bluetooth® Class 1 adapter (up to 100 m range)</td>
</tr>
<tr>
<td>Wired Communication</td>
<td>Automotive A to Mini-B USB cable 15 ft. (5 m) maximum</td>
</tr>
<tr>
<td>Vehicle Connector</td>
<td>DB26F</td>
</tr>
<tr>
<td>USB Connector</td>
<td>Mini jack</td>
</tr>
</tbody>
</table>
# System Requirements

Be aware of the following system requirements:

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM PC-compatible computer</td>
<td>• 1GHz processor or more</td>
</tr>
<tr>
<td></td>
<td>• RAM: 256MB or more (512MB recommended)</td>
</tr>
<tr>
<td></td>
<td>• USB port, version 1.1 or higher</td>
</tr>
<tr>
<td>Operating system</td>
<td>• Windows® 7</td>
</tr>
<tr>
<td></td>
<td>• Windows® 8</td>
</tr>
<tr>
<td><strong>Note:</strong> USB-Link™ 2 drivers support the</td>
<td></td>
</tr>
<tr>
<td>Windows® 8 operating system. However, not all</td>
<td></td>
</tr>
<tr>
<td>OEM PC applications work with Windows® 8.</td>
<td></td>
</tr>
<tr>
<td>Bluetooth® adapter (sold separately)</td>
<td>• Bluetooth® serial port capability</td>
</tr>
</tbody>
</table>
Device Features

The following illustration details the features of the USB-Link™ 2 device.

Figure 2.1 USB-Link™ 2

Legend

A—Vehicle Port       D—Wireless LED
B—Power LED          E—Fault LED
C—Data LED           F—USB Port
The following table outlines the features called out in Figure 2.1.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vehicle Port</td>
<td>Connects the USB-Link™ 2 to a vehicle.</td>
</tr>
<tr>
<td>Power LED</td>
<td>Illuminates when the device receives power.</td>
</tr>
<tr>
<td>Data LED</td>
<td>Illuminates when the device is receiving data from the vehicle.</td>
</tr>
<tr>
<td>Wireless LED</td>
<td>If the USB-Link™ 2 is <strong>Discoverable</strong>:</td>
</tr>
<tr>
<td></td>
<td>• Illuminates when connected.</td>
</tr>
<tr>
<td></td>
<td>• Blinks every second when not connected.</td>
</tr>
<tr>
<td></td>
<td>If the USB-Link™ 2 is <strong>Not Discoverable</strong>:</td>
</tr>
<tr>
<td></td>
<td>• Illuminates when connected.</td>
</tr>
<tr>
<td></td>
<td>• Off when not connected.</td>
</tr>
<tr>
<td>Fault LED</td>
<td>Illuminates when a problem is detected.</td>
</tr>
<tr>
<td>USB Port</td>
<td>Connects the device to your PC (wired connection).</td>
</tr>
</tbody>
</table>

**NOTE:**

When the USB-Link™ 2 is in Discoverable mode, other Bluetooth® devices can detect, pair, or connect to it. When the USB-Link™ 2 is Not Discoverable, it will only connect to a device with which it has previously been paired.

**The Reset Button**

You use the Reset Button on the bottom of the device to change its status. The two modes are:

- Discoverable
- Not Discoverable

To toggle between the two modes, just push and hold the button until all the lights on the front of the device flash, about five (5) seconds.
Communication Options: Wired vs Wireless

Prior to using the USB-Link™ 2, you need to decide how you want the unit to communicate with your PC. There are two options:

- A wired connection to the PC using a USB cable *(pg. 11)*
  or
- A wireless connection to the PC using Bluetooth® *(pg. 12)*

**Wired Connection**

A wired connection provides the advantage of faster data throughput. For that reason, using a USB connection to the PC is *highly recommended* when diagnosing heavily-loaded CAN/J1939 buses. By nature, Bluetooth® has less bandwidth than USB, which can result in dropped messages in situations requiring high bandwidth.

**IMPORTANT:**

⚠️ ECU reprogramming typically requires both high throughput and critical timing, and should *always* use a USB-to-PC wired connection.

Wired communication between the USB-Link™ 2 and your PC requires an automotive A to Mini-B USB cable (shipped with the USB-Link™ 2).

---

**Figure 2.2 Automotive A to Mini-B USB Cable**

**NOTE:**

ℹ️ For detailed instructions on making a wired connection, refer to *Step 4: Connect the USB-Link™ 2 to a Vehicle*, later in Chapter 4 of this manual.
Chapter 2 • Introducing the USB-Link™ 2 Bluetooth Edition

Wireless Connection

Wireless connectivity provides untethered operation, and that’s a bonus in a busy service bay. The USB-Link™ 2 uses Bluetooth® wireless technology to provide wireless communication between the USB-Link™ 2 and your PC.

The USB-Link™ 2 is intended for diagnostic use, for example, retrieving trouble codes. By nature, Bluetooth® wireless technology has limited bandwidth and latency when compared to wired solutions. This may result in dropped messages in situations requiring high bandwidth.

NOTE:

The USB-Link™ 2 does not support Integrated Bluetooth. If your PC has Integrated Bluetooth, your system has Bluetooth® drivers installed and a built-in Bluetooth® transceiver. You must uninstall Integrated Bluetooth and its Bluetooth® drivers prior to proceeding with the USB-Link™ 2 installation process.

If your PC does not have Integrated Bluetooth, then you are clear to proceed with the USB-Link™ 2 installation process as documented in this manual:

• Install Bluetooth® drivers (see Chapter 3)
• Configure the Bluetooth® environment (see Chapter 3)
• Pair the device (See Chapter 4)
• Test the connection using the NEXIQ Device Tester (see Chapter 4)
Chapter 3

Installation and Bluetooth Configuration

- Installation Process Outline, pg. 14
- Step 1: Install the Drivers, pg. 15
- Step 2: Choose Your Connection, pg. 24
- Step 3: Install the Bluetooth Drivers, pg. 25
- Configure the Bluetooth Environment, pg. 26

This chapter provides instructions for installing NEXIQ™ drivers and utilities, installing the required Bluetooth® drivers, and configuring a basic Bluetooth® environment.
Installation Process Outline

Step 1: Install the USB-Link™ 2 drivers (pg. 15).

Step 2: Choose your connection (wired or wireless) (pg. 24).

If you chose a wired connection, move on to complete steps 4 and 6 only.

Step 3: Install the drivers for the Bluetooth® adapter you are using.

NOTE:
Depending on the Bluetooth® adapter you have selected, you may also need to configure the Bluetooth® environment (see Configure the Bluetooth Environment on page 26 of this chapter).

Step 4: Connect the USB-Link™ 2 to the vehicle.

NOTE:
Steps 4 through 6 are described in Chapter 4 of this manual.

Step 5: Pair the Device:

Step 6: Use the NEXIQ™ Device Tester to test the connection between the USB-Link™ 2 and the vehicle.

NOTE:
If you have questions about using this product, contact NEXIQ™ Technical Support at (800) 639-6774, or send us an e-mail at: support@nexiq.com.
Step 1: Install the Drivers

Prior to using the USB-Link™ 2, you have to install the necessary USB-Link™ 2 drivers on your laptop or PC. The USB-Link™ 2 drivers are compatible with both Microsoft® Windows® 7 and Windows® 8.

**IMPORTANT:**

Remember, you must have Administrator security rights and be logged in as “Admin” to successfully complete the installation process outlined in this manual.

The following procedure assumes that you have Internet access.

To install the drivers on your laptop or PC:

1. On your laptop or PC, navigate to the following website:

   www.nexiq.com/downloads

   ![Figure 3.1 NEXIQ™ Downloads](image)

2. From the USB-Link 2 Drivers section, select the latest version of the USB-Link 2 drivers.

3. Carefully read the End User License Agreement.

4. Scroll down to the bottom of the page and click on Accept.
5 Click on the software title to begin the download.

6 Click on Run (if your browser is Internet Explorer®).

**NOTE:**

Depending on your Internet browser (for example Google Chrome, or Firefox®), you may have to locate the file (i.e., USB-Link2xxxx.exe) from your Recent Downloads, and then double-click on it to run it.

The **Welcome to USB-Link 2 Setup** screen is displayed.

![Welcome to USB-Link 2 Setup Screen](image)

**Figure 3.2 Welcome to USB-Link 2 Setup Screen**

7 Read the information displayed on the screen, and follow the recommendations.

8 Click **Next**.
The License Agreement screen is displayed.

![License Agreement Screen](image)

9 Read all the information on this screen, then click I Agree.

NOTE:

If you do not agree to the terms, click Cancel. A message is displayed prompting you to confirm quitting USB-Link 2 Setup. Click Yes to quit.
The following warning message is displayed.

![Warning Message](image)

**Figure 3.4 Warning Message**

10 Carefully read the warning message, and disconnect all RP1210 adapters to which your laptop or PC might be connected prior to proceeding with the installation.

**NOTE:**

You must also exit the WVL2™ Explorer utility if NEXIQ™ WVL2™ drivers have been installed on your laptop or PC.

11 Once you have complied with the requirements of the warning message, click **OK**.
The installation begins and the following screen is displayed.

![Installation Screen](image)

**Figure 3.5 Installation Screen**
If you are running Windows® 7 or Windows® 8, the following **Windows Security** dialogs may be displayed.

![Figure 3.6 Windows Security Dialog](image)

12 Click **Install** to continue.

![Figure 3.7 Windows Security Dialog](image)

13 Click **Install** to continue.

14 Wait briefly while the installation continues.
The **Installation Complete** screen is displayed.

![Installation Complete Screen](image)

**Figure 3.8 Installation Complete Screen**

15 **Click Next.**
The following completion screen is displayed.

![Completion Screen](image)

**Figure 3.9 Completion Screen**

16 Click **Finish**.
The **USB-Link™ 2 Explorer** utility opens.

![USB-Link™ 2 Explorer Utility](image)

**Figure 3.10** USB-Link™ 2 Explorer Utility

17 Move on to “**Step 2: Choose Your Connection,**” next in this manual.
Step 2: Choose Your Connection

You have two options for connecting the USB-Link™ to your laptop or PC.

- Wired connection using a 15 ft. automotive A to Mini-B USB cable
- Wireless connection using Bluetooth®

Choose one of the following options. Both have advantages.

Wired Connection

The advantage of a wired connection is faster throughput (e.g., you want to use the USB-Link™ for ECU reprogramming).

NOTE:

If you are connecting the USB-Link™ by means of a USB cable, you do not need to read the rest of this chapter. Instead, move on to "Connect the USB-Link™ to a Vehicle" in Chapter 4 of this manual.

If you choose a wired connection, you may still want to install the Bluetooth® drivers now rather than later. This will give you the flexibility of wireless connectivity at some time in the future. To install the Bluetooth drivers now, continue reading the remainder of this chapter. Otherwise, move on to Chapter 4.

Wireless Connection

The advantage of a wireless connection is, of course, untethered operation. For a wireless connection using Bluetooth® technology, you must:

- Insert the USB Bluetooth Adapter CD into your PC's CD-ROM drive.
- Install the necessary Bluetooth® drivers.
- Plug the Bluetooth® adapter (i.e., the dongle) into an available USB port on your laptop.

To set up your laptop or PC for wireless connection, move on to “Step 3: Install the Bluetooth Drivers” next in this manual.
Step 3: Install the Bluetooth Drivers

Depending on the Bluetooth® adapter you are using for your wireless connection, you may need to install the necessary Bluetooth® drivers. For some adapters the drivers will install automatically.

**NOTE:**

For best results, Class 1 (100 m range) Bluetooth® USB adapters are recommended. Class 1 adapters are recommended because of their greater operating range.

To install the Bluetooth® drivers:

1. Plug the Bluetooth® adapter you have selected into an available USB port on your laptop, and wait while Windows® installs the required drivers.

   The following message is displayed:

   **Installing device driver software.**

   When the installation is complete, the following message is displayed:

   **Your device is ready to use.**

2. Move on to “Step 4: Connect the USB-Link™ to a Vehicle” in Chapter 4.

**NOTE:**

Some Bluetooth® adapters may require you to configure a Bluetooth environment. If this is necessary, an Initial Bluetooth Configuration Wizard screen will display at the conclusion of the adapter installation process.

If this happens, move on to “Configure the Bluetooth Environment” (pg. 26).
Chapter 3 • Installation and Bluetooth Configuration

Configure the Bluetooth Environment

IMPORTANT:

⚠️ Depending on the Bluetooth® adapter you have selected, you may not need to perform this procedure. If the Initial Bluetooth Configuration Wizard instead does not display, move on to “Step 4: Connect the USB-Link™ to a Vehicle” in Chapter 4 of this manual.

Once you have installed the Bluetooth® adapter, the Initial Bluetooth Configuration Wizard is displayed.

![Initial Bluetooth Configuration Wizard](image)

If the Configuration Wizard does not start up, double-click the My Bluetooth Places shortcut on the Windows desktop.

To configure a basic Bluetooth® environment:

1. Click Next.

Follow the prompts throughout the configuration process.
During the process the following screen is displayed.

![Bluetooth Service Selection](image)

**Figure 3.12 Bluetooth Service Selection**

2. Clear all of the check boxes *except* the **Bluetooth Serial Port** check box.

**NOTE:**

You need to use the scroll bar on the right side of the screen to view all of the check boxes.

3. Click **Next**.
4 Click *Skip*.

The *Initial Bluetooth Configuration Wizard Congratulations* screen is displayed.

5 Click *Finish*.

6 Move on to Chapter 4, *Preparing to Use the USB-Link™*, next in this manual.
Preparing to Use the USB-Link™ 2

This chapter provides instructions for connecting the USB-Link™ 2 Bluetooth Edition to a vehicle, pairing the device, and testing the connection.

It also provides information on using the USB-Link™ 2 Explorer utility, which was installed at the same time you installed the USB-Link™ 2 drivers (see Step 1: Install the Drivers, Figure 3.10 in Chapter 3 of this manual).
Step 4: Connect the USB-Link™ 2 to a Vehicle

The USB-Link™ 2 interfaces with the vehicle by means of any one of the following connectors:

- 6-pin Deutsch
- 9-pin Deutsch
- 9-pin Deutsch - 1 meter
- 6- and 9-pin Deutsch Y
- 16-pin J1962 for OBD II

Making the Connection

There are two connection options:

- Wired connection using an automotive A to Mini-B USB cable (pg. 30)
- Wireless connection using a Bluetooth® connection (pg. 31)

Wired Connection Using a USB Cable

To connect the USB-Link™ 2 to a PC or laptop using a USB cable:

1. Connect the USB cable to the USB port of the PC or laptop.
2. Connect the other end of the cable to the port on the bottom of the device.
3. Connect the DB26 female end of the appropriate adapter cable to the USB-Link™ 2.
4. Attach the other end of the adapter cable (i.e., the Deutsch connector end) to the vehicle’s diagnostic connector.

NOTE:

The vehicle’s diagnostic connector is typically located under the dashboard on the driver’s side, or beside the driver’s seat. It can also be located in the engine compartment, near the electronic control unit (ECU).

5. Move on to “Step 6: Test the Connection to the Vehicle” (pg. 40).
Wireless Connection

When the USB-Link™ 2 is out of range (more than 100 ft.) of the laptop or PC while the application is running, the fault LED will flash until the USB-Link™ 2 is back in range. Plugging the USB cable into the USB-Link™ 2 will turn off the flashing fault LED.

To connect the USB-Link™ 2 to the vehicle:

1. Connect the DB26 female end of the appropriate adapter cable to the connector on the top of the USB-Link™ 2.

2. Attach the other end of the adapter cable (i.e., the Deutsch connector end) to the vehicle’s diagnostic connector.

NOTE:

The vehicle’s diagnostic connector is typically located under the dashboard on the driver’s side, or beside the driver’s seat. It can also be located in the engine compartment, near the electronic control unit (ECU).

— At this point, the Power (green) LED on the USB-Link™ 2 should be illuminated (on).

— If the Power LED is not illuminated, turn the vehicle’s key to the ON position, leaving the engine off.

Step 5: Pair the Device

When two Bluetooth® devices are paired, a persistent link is created between the two devices. This occurs only once; future connections between the devices are authenticated automatically.

If you are running Windows® 7 or Windows® 8, you use the Windows® utility to pair the device (assuming that you chose a wireless connection using Bluetooth®).

**NOTE:**

You may be prompted to enter a pairing code for the device. If you are prompted to enter a PIN or pairing code, enter NEXIQ (all uppercase). See Step 7 on page 37 of this chapter.

To pair the device:

1. Locate the Bluetooth® icon from the system tray on your laptop’s desktop.

![Figure 4.1 Windows 7 System Tray](image)
2. Click on the **Bluetooth icon**.

![Bluetooth Icon Pop-up](image)

**Figure 4.2 Bluetooth Icon Pop-up**

3. Click **Add a Device**.
Chapter 4 • Preparing to Use the USB-Link™ 2

The **Add a device** screen is displayed.

![Add a Device Screen](image)

**Figure 4.3 Add a Device Screen**

4. Select the device displayed that matches the serial number on the back of your USB-Link™ 2 (e.g., **USBL2-012291**).
Your selection is highlighted.

Figure 4.4 Add a Device Screen Refreshed

5 Click Next.
Chapter 4 • Preparing to Use the USB-Link™ 2

The **Select a pairing option** screen is displayed.

![Select a Pairing Option Screen](image)

**Figure 4.5 Select a Pairing Option Screen**

6 Select **Enter the device’s pairing code**.
The **Enter the pairing code for the device** screen is displayed.

![Figure 4.6 Enter the Pairing Code for the Device Screen](image)

7 Enter NEXIQ.
Be sure to enter the code in ALL CAPS.

![Pairing Code Entered](image)

**Figure 4.7** Pairing Code Entered

8 Click **Next**.
The following System Tray message is displayed.

Your device is ready to use.

9 Click Close.

10 Move on to “Step 6: Test the Connection to the Vehicle,” next in this manual.
Step 6: Test the Connection to the Vehicle

You use the Device Tester to test the connection between the USB-Link™ 2 and the vehicle. At startup, the Device Tester checks for any NEXIQ™ drivers installed on the PC.

To test the connection between the USB-Link™ 2 and the vehicle:

1. Click Start and then select Programs > NEXIQ > Device Tester > Device Tester.

   The application is started and the Device Tester screen is displayed.

   ![Device Tester Screen, Showing a Status of Not Connected]

   2. Use the button in the Device box to select the appropriate device (for example, USB-Link2).

      — The Device box lists all the devices supported by the NEXIQ drivers installed on the PC.

   3. Use the button in the Protocol box to select the appropriate protocol (e.g., J1708, J1939, or CAN).

      — The Protocol box lists only the protocols supported by the device selected in the Device box.
4 Press the **Start Test** button.

The **Device Tester** screen is refreshed, and data received from the vehicle bus is displayed in the **Bus Messages** window.

![Device Tester Screen, Showing a Status of Connected](image)

**Figure 4.10** Device Tester Screen, Showing a Status of Connected

**NOTE:**

The **Modules Detected** window in the lower portion of the screen displays a list of all systems seen on the bus. It is used for J1708 and J1939 only. For all other protocols this window will be unavailable (i.e., NOT USED).
If the Connection Indicator button is red (i.e., Not Connected), do one of the following:

—For wireless connection using Bluetooth technology:
  • In the Device list, make sure that the heading is **BLUETOOTH USB-Link** (Protocol desired).
  • Check to ensure that the connections between the USB-Link™ and the vehicle are secure (i.e., the Diagnostic Connector).
  • Check to make certain that the Power LED on the USB-Link™ is illuminated.
  • Check to make sure you are “paired” with devices.

—For wired connection using a USB cable:
  • In the Device list, make sure that the heading is **USB-Link2** (Protocol desired).
  • Check to ensure that the connections between the USB-Link™ 2 and the PC are secure (i.e., the USB cable).
  • Check the connections between the USB-Link™ 2 and the vehicle (i.e., the Diagnostic Connector).
  • Check to make certain that the Power LED on the USB-Link™ 2 is illuminated.

**NOTE:**

For additional information, refer to "Connect the USB-Link™ to a Vehicle" on page 30 of this manual

5 Click **Stop Test** to end the test, or select another device to test.
Using the USB-Link™ 2 Explorer

NOTE:

If you are using a wireless Bluetooth connection, your device will not appear in the list of USBLink2’s in the USB-Link™ 2 Explorer.

The USB-Link™ 2 Explorer utility opened automatically when you installed the USB-Link™ 2 drivers and utilities (see Figure 3.10 on page 21 of this manual).

To re-open the USB-Link™ 2 Explorer once it has been closed, click on the Show Hidden Icons arrow in your PC’s System Tray.

![Figure 4.11 Hidden Icons]

Then, double-click on the USB-Link™ 2 icon.

NOTE:

You can also access the USB-Link™ 2 Explorer from your PC’s Start menu. Click Start and then select All Programs ® NEXIQ ® USB-Link 2 ® USB-Link 2 Explorer.
The USB-Link™ 2 Explorer opens.

![USB-Link™ 2 Explorer](image)

**Figure 4.12 USB-Link™ 2 Explorer**

The following menu options are provided:

- File *(pg. 46)*
- Tools *(pg. 47)*
- Help *(pg. 50)*

Each menu option includes a number of features. Each of the menu options are discussed in the following sub-sections.

When you click on a USB-Link™ 2 in the list in the left pane, the Configuration tab is displayed (Figure 4.13).
The Configuration Tab

The Configuration tab provides the following information:

- Bluetooth Name
- MAC Address

You can use the Bluetooth Name field to change (i.e., personalize) the name of your device (e.g., USB2_Bobs_Bluetooth).

To access the Configuration tab:

1. Click on a **USB-Link2.xxx** in the list in the left pane of the Explorer.

   The Configuration tab is displayed.

2. Review the information displayed.

![Configuration Tab](image-url)
The File Menu

The File menu has one feature, Exit. You use the Exit feature to close the USB-Link™ 2 Explorer.

To exit the USB-Link™ 2 Explorer:

1. Select File from the USB-Link™ 2 menu bar.

2. Select Exit.

The USB-Link™ 2 Explorer closes.
The Tools Menu

The Tools menu provides the following features:

- Ping
- Options

Ping

The Ping feature uses the PING protocol to check for the presence of a device on the network.

To check for a device:

1. Select Tools from the USB-Link™ 2 menu bar.
2. Select Ping.
3. Enter the IP address of the device you want to locate (e.g., 192.168.123.107).
4. Click Start.
   
   The USB-Link™ 2 Explorer searches for the device and, if found, displays the reply.
5. Click Stop.
6. Click the Close button on the dialog box.
Options

The Options feature provides the following features, which are presented as check boxes:

- Start USBLink2 Explorer when Windows starts (pg. 48)
- Show New USBLink2 Notification (pg. 49)

**Start USBLink2 Explorer when Windows Starts**

You use this feature to manage when the USB-Link™ 2 Explorer opens.

The default is to automatically open the USB-Link™ 2 Explorer when Windows starts.

![Options Menu](image)

*Figure 4.16 Options Menu*

To change the default, click on the check box to remove the check mark. Then click **OK**
Show New USBLink2 Notification

You use this feature to manage when to display the New USBLink2 notification message box.

The default is to display the notification message box when a new USB-Link™ 2 is detected.

To change the default, click the box to remove the check mark. Then click OK.
The Help Menu

The Help menu has one feature, About. You use the About feature to display information about the USB-Link™ 2 Explorer.

To access the Help menu:

1. Select Help from the USB-Link™ 2 Explorer menu bar.
2. Select About.

3. When you have finished reviewing the information, click OK to close the dialog box.

![About USB-Link 2 Explorer](image)

*Figure 4.19 About USB-Link 2 Explorer*